D'ni Firemarble Holder
by Gary Butcher 


Before I start with this tutorial I'd like to make a few notes: 

1 - I'm probably one of the world's worst tutorial writers.. you have been warned! 

2 - I'm doing this under threat of bodily violence from Pedja, so if I don't write it I'm in trouble ;) 

3 - This isn't going to be super detailed, but anyone with a reasonable level of Max proficiency should (hopefully) do OK with it. It's written for housebroken beginners and intermediate level Maxers who don't want hand-holding all the way. 

4 - Your end results, if you render the supplied file, should look similar to the original picture supplied. However, the file is a slightly simplified version so it won't look exactly the same. BTW, use 'Render Region' to get the right shape or crop afterwards as it's ugly with the default aspect. 

5 - All Axis settings are based on a user views where Z = UP unless otherwise stated. I almost always work in User Views. 

6 - Tutorials like this are not the 'right' way to do things, it's just the way I did it. 

7 - It was made in Max 3.1 and may bitch about not finding 'Ghost' plugins.. ignore it. 

I'd like to thank Neil Blevins for providing the inspiration for the picture as well as some of the mesh and materials, and Pedja for hosting a great site and giving me the opportunity to embarrass myself in public on a grand scale. 

A little background info first, the idea for this picture came originally from my work at Cyan and the D'ni civilisation which Cyan created. Just so you know, a firemarble is a small sphere which glows, this is placed in a holder, essentially making a torch. 

Onto the fun...

Lining up for part one: Shaping

The first thing to do is draw out the splines (shapes) which will make up the major objects, these are the glass handle, the brass fixing ring, the brass holder itself and the brass retaining spring, labeled in Fig.1 as Handle, Ring, Holder and Helix. All other objects are standard Max primitives. When making a symmetrical object like this it often helps if you first setup a datum line to represent the object center and lathe axis (seen in Fig.1 as 'Axis' in yellow). The Handle and Ring are both Bezier splines, the Holder is a linear spline and the Helix is one of the default Max spline primitives. Except for the Helix, these have been drawn so they overlap and fit together as the modeling progresses for easier visual referencing. 



The Handle and Ring splines are drawn anti-clockwise starting from the axis point to make a predictable lathe which has it's faces pointing the right way. Adjust the Bezier handles to get the shape you want, it's not essential that you slavishly follow my exact drawing, tutorials are your guide, not your god :) The Holder spline was constructed by making one half, then mirror-copying (main toolbar>Mirror Selected Objects), applying an >Edit Spline< Modifier, attaching the two parts and welding their vertices together. It's generally a good idea to make them like this when you require accurate symmetry. It's essential to use Linear when Making the holder spline as we'll be adding a >Meshsmooth< modifier later. You can see roughly how many spline steps I used in Fig 2. 

[image: image1.jpg]


Fig.2 

The Helix is accessed from the Command Pane l>Create >Shapes >Helix<. This will show you the Parameters to make your Spring (Fig 3). As you can see, it's tapered and has a -bias setting to make the coils bunch up at the base. This gives the coils a nice look and helps balance the look of the holder. This look will be enhanced in the lofting process later. 

[image: image2.jpg]


Fig.3 


Hopefully you now have a great set of splines ready for the next stage.... Solidifying. 

First we'll lathe the handle. I gave it 32 segments which is smooth enough for most purposes; adjust as you wish. Set the lathe Alignment to 'Min' and 'Weld Core'. This should result in a nice, smooth handle. Do the same for the Ring object. 
Next, extrude the Holder in the Z-axis with 2 segments until it looks right in relation to the other bits and position this centrally to the handle (See Fig 4). If yours looks like that, then all's well in the world. That's the easy stuff out of the way :) 




Fig.4 

Next onto the Spring lofting, you'll need a pair of circle shapes -- one large, one smaller, as seen in Fig 4a, 'Profiles'. The exact size doesn't really matter, as you can adjust these shapes interactively later to get just the look you want. Select the Helix, go into Create >Geometry >compound Objects >Loft< and click the 'Get Shape' button. Click on the big circle and it should make a solid spring mesh, set the 'Path Parameter' to about 60 and click on the small circle, set the path to 85 and click on the small circle again, then 100 and click on the big circle. 

You should now have a loft that starts thick, thins in the middle and thickens again at the top. If you now go into the Modifiers panel with the loft selected, you can go into SubObject >Shape<, select whichever of the four shapes you want to adjust, and re-scale them with the scale button on the main toolbar. 
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Fig.4a 


Once you're happy, move onto the next section... 

Tweaking

First we'll tweak the Handle. All I really wanted to do here was squash the fat end a little to make it elliptical while keeping the rest rounded (see Fig 5). An FFD box (Modifiers >FFD box<) is ideal for this. (If you can't find it, look in 'More'.) I set the segments to: Length 6, Width 2 and Height 2. Go into Sub-Object >Control Points< and select the end four points. Use Non-Uniform scale and scale in the Z-axis until the handle end has a nice oval shape. Select the next four points and scale down in the Z-axis just a little to keep continuity and avoid a bulge, as FFD's tend to work like a bezier -- as you lower one end knot, the other end goes up. 

[image: image5.jpg]


Fig.5 

Next is the Ring. This is a bit simpler. All we need to do is apply a Non-Uniform Scale to the object itself in the Z-axis until it matches the shape of the handle end. You can use the handle's wiremesh as a guide for this (see Fig 6). 
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Fig.6 


Holder next. This is a more complicated tweak. First thing it needs is to have a bevel applied to the top and bottom faces. Add an Edit Mesh modifier (Sub-Object >Polygon<) and select the top and bottom faces. In the Edit Geometry panel, choose 'Bevel'. Adjust the bevel so it looks similar to Fig 7. Again, super accuracy isn't the aim here; as long as the bevel doesn't intersect itself, it'll be fine. 
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Fig.7 

We need to pull some vertices around to give the holder some initial shaping. Select rows of vertices in the *side* view and Non-Uniformly scale them in the Y-axis (up). See Fig 8. Once you have shaped the end that attaches to the handle, select all the remaining vertices (shown in red in Fig 8). 
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Fig.8 


Add a 2x2 FFD to the selected vertices as shown in Fig. 9 and Non-Uniform scale the points in the Z-axis (up) until they taper in at the marble end. Make a Sphere (marble) and position it so it's up against the inner edges of the tangs (prongs) of the holder. 
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Fig.9 

Now we need to extrude the little arm thingy in the middle. This is done in a few steps. It's not very hard to do, just hard to explain. As a picture is said to be worth a thousand words, I've shown the various steps in Fig 10. You figure it out! OK, just kidding :) 




Fig.10 


We need to 'grow' the arm from the holder mesh using Bevel, Extrude, and some vertex pulling. In Edit Mesh >Polygon >Bevel<, select the faces shown in red in the first image (A). These are then beveled out (B). Then go into Vertex mode and select Target Weld'. Pick the two center-side vertices at the end of the bevel, and pull them to meet the top ones where they should weld themselves. Take the center top vertices and pull them to the side vertices to make one large poly where previously there were four (C). Go back into Polygon>Bevel mode and bevel out that one poly until it looks like (D). 

Extrude the end polygon four short steps and move the resulting vertices to curve the end around the Marble (E). Select the three top and bottom end polygons as seen in (E) and extrude them (F). Pull those top faces in the direction of the arrow in (F) until it looks like (G). Then you need to pull back and lower the vertices above the start of the arm to smooth the slope from the top plate to the arm. 

You may need to do some edge turning and dividing, depending on how your mesh was created, to avoid intersecting faces while adjusting the vertices.

Add a Meshsmooth modifier to the holder (H) using Nurms, Quads, and Keep Faces Convex. Two iterations are good, although once you're happy with the mesh, you may want to keep iterations to 0 and Render Value iterations to 2 for the sake of operational speed as this will subdivide at rendertime. If the Meshsmoothed shape looks a bit off, drop back down the stack to 'Edit Mesh' and adjust the vertices until you're happy. 

The last thing to do is adjust those square corners where the Holder meets the Ring. Add an Edit Mesh modifier using Soft selections in vertex mode, set to a fairly small (5-15) falloff range. Click a corner vertex and pull a short way towards the center, as shown in Fig 11. Repeat on all four corners to taste. 
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Fig.11 


Tweaks over -- now to put the other stuff on it...

Accessorize

Position the spring over the little arm and scale to suit. Make a Torus (Hoop). Rotate the Torus to look like it's hanging down and place it at the back of the handle.Remove the faces inside the handle (Fig 12). Add smaller Torii as eyelets where the big Torus joins the handle. 
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Fig.12 


That's it, modeling over! If what you have looks *anything* like Fig 13, you've done what few have ever managed -- actually made sense of my ramblings! Congratulations! 




Fig.13 

Man, this thing looks lonely... Time for some scenery. 

This is where I pilfer Neil's work and claim it for my own ;)) 

OK, scenery is a bit strong for what we're actually going to do -- as Neil showed, for many scenes, less is more. The basic setup is designed to show off nice reflections in glass. Neil made an 'L' shaped backdrop with a self-illuminated black-to-white gradient, a few self-illuminated white panels scattered around, and two Omni lights in a black environment (Fig 14). 




Fig.14 


I added a few things to this to make it work better for my scene. I kept all Neil's original stuff, added one Omni light and one plane, and changed the Environment to a bitmap. I tend to do things a little differently in that I don't use a real 'floor' surface for many pics; what you see is the environment map and some shadows cast onto an invisible plane with a 'Matte/Shadow' material added. I did this for my Doggy, Dirty Microscope, Watch, and Dirty Gun pictures. The effect looks like a solid surface while providing smooth reflection transitions without inconvenient reflection breaks. 





 HYPERLINK "javascript:showImg('dni/microscope.jpg')" 

 INCLUDEPICTURE "http://www.3dluvr.com/content/artz/3dsmax/std/dni/microscope_s.jpg" \* MERGEFORMATINET 



 HYPERLINK "javascript:showImg('dni/watch.jpg')" 

 INCLUDEPICTURE "http://www.3dluvr.com/content/artz/3dsmax/std/dni/watch_s.jpg" \* MERGEFORMATINET 



 HYPERLINK "javascript:showImg('dni/dirtygun.jpg')" 

 INCLUDEPICTURE "http://www.3dluvr.com/content/artz/3dsmax/std/dni/dirtygun_s.jpg" \* MERGEFORMATINET 




The additional Omni is positioned using the 'Place Highlight' tool (in the Align dropdown) to make a bright spot on the top of the marbleholder Ring. All else is excluded from this light. The plane with the Matte/Shadow material is positioned just above the original 'L' shaped base. This allows the environment map to show through the 'L' shaped mesh. I adjusted the environment picture rotation/offset until the area under the holder and the glass reflections in the handle looked good. This takes time and patience to get just right but I like the look enough to persist with it. You'll see what I mean if you open the file.

Yeah, I know my modeling looks crummy, but luckily I can hide all that with..... *textures* :) 

Here comes the other fun part, making a silk purse out of a sow's ear! My old fav's Glass and Brass rear their ugly heads once again to make a special appearence. The Materials are simple and quick but quite effective. The glass is a slightly modified version of Neil's sample, using a Raytrace Material with a 1.5 IoR, gold/yellow colored transparency, fawney colored diffuse and a Falloff Map in the reflect slot set to 80%, 80% settings with black in the top slot and white in the lower slot. 

The Blue glass is similar but with a blue transparency setting and an IoR of 3.0. 

The three Brass materials are Standard Max materials with metal shading and a variety of map types. One has a diffuse bitmap, one has a diffuse falloff map, and one has no map. The falloff map is two shades of gold/brown which are on the Spring and Hoop. The diffuse bitmap is a matching one for a bump map that goes on the Holder Ring to give the engraved pattern (supplied). The one without a map is on the holder. 

The reflections on the brass are all the same: a mix material in the reflect channel with the Watch picture (supplied) set to Spherical Environment, rotated 180 Deg. and blurred 0.012 in slot 1, a Raytrace map in slot 2, and the Mix slot with a Falloff map set to 80%, 80% black on top, white below. 
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Materials 


These materials are all supplied in Smegmat.mat. 

The only items that needed mapping coords are the backdrop mesh and the Ring. The Ring has a cylindrical UVmap, not capped and Non-uniformly scaled in Z to fit the mesh so that the mapping sits evenly around the oval shape. The brass textures should work well in any environment, but the glass is a lot more picky about where it's seen. The last thing to do is to select all the bits of the firemarble holder and group them for easy positioning and rotating. 

At the end the finished image is below and here is the MAX scene file along with the maps: marbleholder.zip. 






Also check Neil's original tutorial at: 
http://www.neilblevins.com/cg_education/tut12/tut12.htm 

Have fun! 

Smeggy :] 
Edited by Smegwif :)
